Repairing of kitchenaid phase control board

It’s a story how I spent thee days troubleshooting 9 elements circuit when 7 of them are passive. I didn’t found what’s wrong, but fixed it.

I have  control board marked as W10354309, it’s European 220V model of phase regulator.
I wonder which logic behind kitchenaid’s parts marking, I found several part numbers for 220V version: 3184417, 4163707, 4163712, 9701269, 9706596, W10217542, W10538289, W10911442, W11174552, WPW10538289
(110V version have same idea and same schematic, just different values and ratings for some elements)
I don’t know why they do that. Probably because they use the same part on different models and/or under different brands.
So, I have 5ksm125 mixer and W10354309 phase control.

Service manual says, that at the first speed planetary shaft should have near 60RPM, but in my case it had near 120RPM and I was unable to decrease it by tuning control plate.

Here I should make a digression, these mixers have ability to maintain constant RPM under different load.  I was surprised when I learn how do they do that. One of the main component comes right from the steam engine era, it’s centrifugal governor which is placed on the shaft of the motor, here it is:

Yellow thing is the governor itself, black cylinders highlighted with green – weights, central pin stroked with blue is a pin which provides feedback to control plate. It works simple, the more RPM motor have the more pin extends.

Next component is so called control plate, in fact it has simple main switch and a T shaped contact. The main switch  just break circuit when you move switch lever to off. T-contact plate just shorts contacts on a plate in 3 different configuration. The white tab on a picture above is a dielectric tab on T-contact, governor’s central pin pushes this tab and changes which contacts are closed on control plate. Here is control plate from the other side:

And the last component is a phase control board, it’s basically dimmer if you google for ‘dimmer circuit’ you will find the same scheme as used in phase control board with one exception, usually dimmers have variable resistor for smooth regulation, phase control board has resistors network in which resistors shorts by control board in 3 different configuration. You can see it  behind top edge of contral board on the picture above and on closeup photo on picture below:

So, how its work together? Here is schematic from repair manual with comments and nominals added by me:

As I sad before control plate can be in 3 different states:
The first: the motor has too low RPM or doesn’t turn at all. T-contact fully closed, it shorts resistor network (R1, R2, R3, R5) completely and feeds motor with almost full sine wave (DIAC Q2 opens at around of 30V, so the start of the wave is chopped a little bit)
The third: the motor has too much RPM. T-contact fully opened, resistors network has maximum resistance,  phase control board feeds motor with minimum amount of energy (manual says that it should provide 40V RMS, I don’t understand why it’s true for both 110V and 220V version, but looks like it is).
The second: this state is somewhere in between too low RPM and too much RPM, control board shorts R1, equivalent resistance is ((R5+R3)* R2)/(R5+R3+R2), manual says that it should provide 80V RMS.

The more RPM motor have, the more central pin of centrifugal governor extents, the more it shift T-contact. When T-contact shifting, it opens circuit with bottom contact first and with upper contact next (check schematic above). When you select mixer’s speed you change distance between control plate and governor, the more distance it has the faster motor should spins to get equilibrium between the first and the third states.

Finally I can tell about my issue.
Usually when phase control is broken mixer doesn’t cho-cho at all or doing it on max speed, my story was slightly different, it had near 120 constant RPM on the first 3 speeds, next speed or two  increased RPM to the maximum, and other speeds did nothing.

When I saw schematic, I was pretty sure that I just need to replace DIAC. In circuits like this, if something works wrong in 99 cases of 100 it caused by broken semiconductor. When TRIAC failed it usually stays open or shorted (motor shouldn’t run at all or run at full speed).

I changed DIAC but  nothing changed, motor had RPM above nominal, but not the maximum. RPM was enough to extent governor’s central pin to the maximum and open both contacts on control plate.

The next suspect was TRIAC, here is only two semiconductors, if one of them is OK, the other one is broken, right? Wrong. I tried two different TRIACs without success. BTA12-600SW (it has the same characteristics like original one. Logic level gate, gate’s current 10mA , snuberless, but rated for 12A instead of 6A) and BTA06-600CW ( it isn’t logic level and had gate current around 35mA, it produced visible sparks during re-commutations on control plate, so don’t use it).

What should be suspected next? Capacitors? Both had less than 5% difference of capacitance from their nominals. I tried other capacitors, RPM of motor changed, but not significantly (in theory failed capacitors may have noticeable different capacity under high voltage, but I tested them with low voltage LCR meter).

After that I started to go crazy, I even de-solder every resistor, but they had correct values.
I spent near 3 days trying to find what’s wrong.
I had a lot of theories: failed resistor which heats when voltage applied and changes its resistance, semi-broken wires, semi-broken motor etc.
I even found a topic in which people had the same issue, but no one find the solution:

Soon after I started my experiments, I found that everything works as expected when I put R4 with increased value, but I wanted to find why circuit which had right elements didn’t work as it should.
At the end of the third day I gave up. I tried to replace every resistor, every capacitor in circuit and it didn’t helped, I tried to solder wires in parallel with existent,
In the end I decided to put 3.6KOhm R4 instead of original 560Ohm.

Here is my observations:

  • Manuals says that you can check phase control by putting sheet of non conductive material (like papper) between T-contact and contact which it touches, if it’s OK it should provide around 40V, but I got 50V. When I lovered voltage to 40V I got response from control plate regulation.
  • Motor starts spinning at around 9V DC.
  • Coils of stator has resistance of 7.8 Ohm each, rotor has resistance near 4 Ohm between nearest contacts, resistance of motor (between red and white wire) near 40 Ohm.
  • Circuit is sensible to element’s values, even when I tried to put capacitors with the same value I got slightly different RPM. My circuit has 1% R5, old scheme from manual has 3 resistors in series, usually this approach used when resistors have breakdown voltage less than voltage drop on them or when you want to use few cheap 5% 10% resistors instead of precise one.
  • Probably phase control boards with  different part numbers more stable. I found photos of others boards and saw that resistors have values different from values that observed. Here is an example from amazon:

14 comments on “Repairing of kitchenaid phase control board

  • zeev says:

    I have found it very interesting.!
    my machine is starting go just after I “push” it, “help” it to start the action.
    where’ do you think should I look for the problem?

    • Ivan says:

      Hello, I don’t really sure that understood you correctly. Do you mean that you need to help mixer to start rotation? Like physically rotate whisk to make it work?

    • gth_42 says:

      Check for dirty brushes and glazed/carbon-ated commutator. Note, these brushes are keyed and have light springs. Less than about 3/8″ of brush remaining makes these surge a bit. Once rotating, the motor needs less current, and arcing of the brush/commutator helps maintain contact.
      Also check the shafts for binding. The PTO and planetary output shafts have generally poor lubrication.

  • tamade says:

    Had the same problem, the culprit was finally traced to a bad capacitor C2 100nF 250V.

    • Ivan says:

      I don’t remember if I tried to replace C2 with another one, but now looking back, I understand that I tested its capacity under low voltage. It probably degraded in a way that caused it to lose capacity at higher voltage but remained within spec for lower voltage.

  • Eric says:

    I’m not an electrical engineer but I wish I was. Your explanations gave me a rudimentary understanding of how things work, and for that I am grateful. Thank you.

  • Art Leonard says:

    Thank you for great detail. I have not solved my problem yet but this should allow it. I’m so grateful for the circuit diagram. The connectors to the sensor board are a little misleading (if you don’t examine each one carefully). Saved me from having to do that and then questioning my results. I am now more comfortable with the idea of modifying the resistor values.

  • I had the same problem, the mixer was revving way too high on the small steps, unable to be adjusted from the centrifugal regulator plate screws. After hours of trying various resistor values, I removed the triac and noticed that it was driving without being commanded into the gate. After I replaced it with an insulated capsule (mandatory in this case), I replaced the two resistors in series with one of about 680k and everything was OK. I’m sure the problems that other users have also had triac degradation as the main cause.

    • Ivan says:

      My first suspect was diac. I tried to replace both diac and triac without success, only difference I saw is between standard and logic-level triac. With standrat triac sparks on control board were much stronger, so logic level is must have otherwise it will shorten contact’s life which are much more complex to repair.

  • I had a similar problem, the mixer was running at high speed and could not be adjusted from the centrifugal regulator. After hours of fiddling with various resistor values ​​and capacitors, I decided to remove the triac and test it separately. When testing for DC current and voltage low, everything seemed OK, but stringing a light bulb with a power cord and testing the triac in AC, it was conducting without being driven into the gate. I changed the triac to one with an insulated cap (required) and replaced the two stringed resistors with one of about 680k and everything was OK. Consider that when all other components are fine, the only thing left to change is the triac….

  • Daniel says:

    Thank you for this article! It helped me tremendously. I replaced R4 with a 6.2k which sort of does the trick. I was wondering if an increase in the effective feedback resistance (R1, R2, R3, R5 combination) in the third state (too much RPM) will not be a better solution. You will have to play around with the values to get state two at 80V and of course state 1 will be at 110V.

    • Ivan says:

      I’m glad that it helped you.
      I still not sure why in my case it stopped working. I tried to replace each element with the new one, but it didn’t helped. Probably characteristics of multiple elements or motor itself was degraded, so I used potentiometer to find the sweet spot and replaced it with closest value resistor after that.


Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>